Author Topic: Clutch on t20  (Read 78 times)

Offline wedge

  • Trade Count: (0)
  • Master 6x6'er
  • *****
  • Posts: 981
  • Country: us
  • Karma: +0/-0
  • Run it like a Big Block !
Re: Clutch on t20
« Reply #5 on: January 13, 2018, 09:01:44 AM »
Usually clutch issues that cause a vibration will be present in neutral as the engine is brought up to speed. If only when moving most likely is bent axle or sprocket damage.  Hope you find it.
iagree
1, Amphicat. 1, StarCraft. 2, Max 2's And Counting

Offline Msafi65

  • Trade Count: (0)
  • 6x6'er
  • **
  • Posts: 30
  • Country: us
  • Karma: +0/-0
Re: Clutch on t20
« Reply #4 on: January 11, 2018, 09:28:35 PM »
Usually clutch issues that cause a vibration will be present in neutral as the engine is brought up to speed. If only when moving most likely is bent axle or sprocket damage.  Hope you find it.

Offline Delduck

  • Trade Count: (0)
  • Full 6x6'er
  • ***
  • Posts: 146
  • Country: us
  • Karma: +0/-0
Re: Clutch on t20
« Reply #3 on: January 11, 2018, 08:31:06 PM »
Whipper I will check for that stuff tomorrow now that I have a idea what to look for.   Thank you

Offline whipperag

  • Trade Count: (1)
  • Full 6x6'er
  • ***
  • Posts: 229
  • Karma: +0/-0
Re: Clutch on t20
« Reply #2 on: January 11, 2018, 08:27:36 PM »
I seem to have a bad shake in my machine while itís moving. Is it possible to have spun or messed up the red spring.
Not likely, unless it was put in wrong.
Is the bolt that holds the clutch on tight???
Are the nuts loose that hold the T-20 down tight???
 popcorn popcorn popcorn popcorn

 nopics
Whipperag

Offline Delduck

  • Trade Count: (0)
  • Full 6x6'er
  • ***
  • Posts: 146
  • Country: us
  • Karma: +0/-0
Clutch on t20
« Reply #1 on: January 11, 2018, 06:52:47 PM »
I seem to have a bad shake in my machine while itís moving. Is it possible to have spun or messed up the red spring. Everything looks fine BUT,  I donít even know what to look for.